WordPress Networks, MediaTemple, Plesk and bouncing email

Over the past couple of days, I’d gotten a few phone calls from prospective clients who told me they were using the contact form on my Digital Strategy Works website to submit an inquiry about our services, but they hadn’t heard back from me. Huh, I wondered. Really? How could this be?

I did some preliminary investigating and there didn’t seem to be a problem with the Contact Form 7, which I use for my forms. WordPress itself and my server were running normally. After clicking around, it was time to test the form for myself.

I sent myself an email through the form and got back the following (removed the @ symbol to obfuscate address):

Hi. This is the qmail-send program at netmixsupport.co.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<az(at)tonyzeoli.com>:
This address no longer accepts mail.

--- Below this line is a copy of the message.

Return-Path: <tonyzeoli(at)me.com>
Received: (qmail 25887 invoked by uid 110); 13 Jan 2012 21:47:22 -0500
Delivered-To: 1-admin(at)netmix.co
Received: (qmail 25882 invoked by uid 10001); 13 Jan 2012 21:47:22 -0500
To: admin(at)netmix.co
Subject: tonyzeoli(at)me.com
X-PHP-Originating-Script: 10001:class-phpmailer.php
Date: Sat, 14 Jan 2012 02:47:22 +0000
From: "tonyzeoli(at)me.com" <tonyzeoli(at)me.com>
Message-ID: <[email protected]>
X-Priority: 3
X-Mailer: PHPMailer 5.1 (phpmailer.sourceforge.net)
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
Content-Type: text/plain; charset="UTF-8"

From: tonyzeoli(at)me.com <tonyzeoli(at)me.com>
Subject: test

Message Body:
test
--
This mail is sent via contact form on Digital Strategy Works http://netmix.co/digitalstrategyworks

I though, that’s odd. The qmail-send program should be sending an email from the server to the email address I’d set in the admin panel of the Contact Form 7 plugin. But, I was getting a bounce back to the email address I’d tested in the form, saying that the address I was sending to was undeliverable. Why was it undeliverable, when I get email to my tonyzeoli.com address all the time?

There were a couple of reasons. First, I am using Google’s hosted mail service to handle mail for a couple of my domains: tonyzeoli.com and tonyzeoli.com. Second, when I set up my WordPress network on MediaTemple VPS, I needed to add a “domain alias” for each domain name that would be included in the network. While I added Netmix.com and DigitalStrategyWorks.com to the MediaTemple administration panel, you’re required to access the root domain of your WordPress network and add those domain aliases.

My root domain is netmix.co and my domain aliases were added to that account in my control panel. The image below is a screenshot of the control panel. Under “Websites and Domains,” click the “Show Advanced Operations” text link at the mid point of the page, which will drop down an extended set of options. Highlighted in the red square is the link to “Domain Aliases,” where you can add or manage all of the alias domains you’re going to use in your WordPress network. Remember, just because you’ve added them in your MediaTemple account center, does not mean that they will work. They must be added as a domain alias in your primary domain’s control panel or none of your domains will resolve correctly in your network.

Image of control panel otherwise known as a "Cpanel" for Plesk clients using MediaTemple web hosting services
Websites and Domains admin in Plesk Cpanel

After you have clicked on the Domain Alias link, you can add the domain aliases. In the image below, you can see a list of domain aliases that I have added so that the domain mapping plugin for WordPress can redirect to each domain alias assigned under the primary domain.

Image of the domain aliases administration area in Plesk CPanel if using MediaTemple hosting
Plesk CPanel Domain Aliases administration panel

Now, here’s what I found that was causing the inadvertent mail issue. Since I’m using Gmail hosted mail services for two of my domains, tonyzeoli.com and tonyzeoli.com, I am not using the qmail feature of the server to send email directly from the server. The two domains in question, tonyzeoli.com and tonyzeoli.com inherit the local functionality of the qmail server, but we don’t want that, because my email DNS entries are listed as Google’s and not MediaTemple’s. Aha! Therein lies the problem. The domains are not accepting mail, because they are set to use the local mail server and not the 3rd party Google hosted mail server!

If you are hosting your email through a 3rd party service and not using the local mail feature, you’re going to get this issue where mail cannot be delivered to the domain, because the server is trying to use local mail and not the Gmail system. How do you fix that? Easy, just click on any one of the domains that you’re hosting mail for using Google or another service, and then turn off the local mail service. Problem solved!

Netmix Mail Service Domain Alias CPanel Plesk
Netmix Mail Service Off

4 comments

  1. MTmattL says:

    Great write up Tony. Two very valid points that many customers tend to look over regularly. Glad to see you were able to work things out, though. Feel free to contact us any time if you have questions in the future.

    • djtonyz says:

      Thanks, Matt. There are some things you just can't know until they happen to you. There is no school or training for every little issue that arises. I'm happy to alway help others by sharing my knowledge. MT has been as strong as an ox for me and my projects.

  2. Awesome post there Tony. I run a bunch of sites off a single DV box and only came across the issue a few days ago.

    It all works now thanks to you (and a few pointers from the MT crew)

  3. T.J. says:

    I have been having this same problem, but when I tried this I get this error when trying to add a domain alias : Error: Incorrect name of domain alias shopwalkinlove.com, domain shopwalkinlove.com already exists.

    Any idea what I should do?

Leave a Reply